iRWX.RU

Personal IT notes.

Cisco: ASA + Etherchannel + Failover + Multicontext

Сразу ремарка: IP SLA, Route Tracking в режиме Multicontext НЕ РАБОТАЕТ. Функционал давно запрошен (требует логин), но «воз и ныне там». Проверяйте документацию. На момент написания статьи в софте версии 9.8 данного функционала не было. Если нужно переключение между провайдерами внутри контекста, используйте протокол маршрутизации.

Начнем.

Схема физическая:

Имеем некий пограничный коммутатор. В него подключено 2 провайдера, DMZ, локальная сеть. Все это «хозяйство» VLAN’ами спускается по etherchannel на 2 Cisco ASA, объединенные в active/standby failover. Между Cisco ASA также настроен etherchannel.

Схема логическая:

Здесь ASA имеет соседа в EIGRP и получает от него анонс внутренней сети 10.10.10.0/24. Также ASA имеет соседей в OSPF в виде провайдерских шлюзов и получает от них анонсы маршрута по-умолчанию.

CTX-ADMIN, CTX-MAINGW — названия административного и рабочего контекстов.

В данном примере выбор и настройка протоколов маршрутизации имеет цель показать, что без пиринга с провайдерами не реализовать переключение между ними. В наличии у меня была ASA OS версии 9.1.5, поэтому использовал то, что имелось на борту — EIGRP и OSPF. BGP внедрили в более поздних версиях.

Задачу по настройке Cisco ASA разделим на 3 последовательных этапа:
1) настройка etherchannel’ов;
2) настройка failover’а;
3) настройка административного и рабочего контекстов.

Настройка EtherChannel.

Настраиваем ASAv_9.15-1.

— Удаляем старые настройки и переводим Cisco ASA в режим поддержки контекстов безопасности:

write erase
mode multiple

(перезагрузка)

— Создаем etherchannel’ы в сторону пограничного коммутатора и в сторону ASAv_9.15-2 для организации failover линка.

interface ethernet 0 
 channel-group 1 mode on
 interface ethernet 1         
 channel-group 1 mode on
interface port-channel 1
 description TRUNK_TO_BORDER_SW
 sh
 no sh

interface ethernet 6
 channel-group 2 mode on             
 interface ethernet 7          
 channel-group 2 mode on
interface port-channel 2
 description FAILOVER_LINK
 sh                      
 no sh

Настраиваем ASAv_9.15-2.

Настройка абсолютно идентична ASAv_9.15-1.

Настройка Active/Standby Failover’а.

Настраиваем ASAv_9.15-1.

Данная Cisco ASA будет первичной в failover’е.

failover lan unit primary
failover lan interface FAILOVER_IF Port-channel2
failover interface ip FAILOVER_IF 192.168.0.1 255.255.255.252 standby 192.168.0.2
! Линк для statefull failover. Не рекомендуется использовать низкоскоростные линки.
! Если не настраивать - получим stateless failover.
failover link FAILOVER_IF Port-channel2
! включаем failover
failover

Настраиваем ASAv_9.15-2.

Настройка почти идентична за исключением роли в failover’е — secondary.

failover lan unit secondary 
failover lan interface FAILOVER_IF Port-channel2
failover interface ip FAILOVER_IF 192.168.0.1 255.255.255.252 standby 192.168.0.2
! Линк для statefull failover. Не рекомендуется использовать низкоскоростные линки.
! Если не настраивать - получим stateless failover.
failover link FAILOVER_IF Port-channel2
! включаем failover
failover

Failover у нас собран, настройки между unit primary и unit secondary синхронизировались.
Все дальнейшие настройки производим только на ASAv_9.15-1.

Настройка контекстов безопасности.

— Для удобства изменим отображение имени устройства в консоли:

ciscoasa(config)# prompt hostname context priority state 
ciscoasa/pri/act(config)# 

— Перейдем в системные настройки.

changeto system

— Разберем на сабинтерфейсы теги VLAN’ов, приходящих по etherchannel с пограничного коммутатора.

int port-channel 1.100
 vlan 100
 description WAN_ISP_1
 no sh

int port-channel 1.200
 vlan 200
 description WAN_ISP_2
 no sh

int port-channel 1.300
 vlan 300
 description DMZ
 no sh

int port-channel 1.400
 vlan 400
 description LAN
 no sh

— Укажем генерировать автоматически уникальные МАК адреса интерфейсов контекстов безопасности для классификации пакетов, между shared интерфейсами.

mac-address auto

Настраиваем административный контекст.

Данный контекст будем использовать исключительно для управления, заниматься передачей трафика он не будет.

! переходим в системные настройки
changeto system

admin-context CTX-ADMIN 
context CTX-ADMIN
 config-url flash:/CTX-ADMIN.CFG
 allocate-interface port-channel1.400 LAN_IF

LAN_IF — название интерфейса под которым он будет виден внутри контекста.

Проверяем:

# sh context 
Context Name      Class      Interfaces           Mode         URL
*CTX-ADMIN        default    Port-channel1.400    Routed       disk0:/CTX-ADMIN.CFG

Total active Security Contexts: 1

— Перейдем внутрь административного контекста и настроим SSH.

changeto context CTX-ADMIN

interface LAN_IF 
 nameif LAN
 security-level 100
 ip address 10.18.0.11 255.255.255.0 standby 10.18.0.12

! заводим пользователя
username cisco password cisco privilege 15

! аутентифицировать пользователей SSH  в локальной базе Cisco ASA
aaa authentication ssh console LOCAL 

! генерация ключа SSH
domain-name HQ.CORP
crypto key generate rsa modulus 2048

ssh 10.0.0.0 255.0.0.0 LAN 
ssh version 2
ssh key-exchange group dh-group14-sha1 

! дефолт в сторону LAN_CORE_GW
route LAN 0 0 10.18.0.3

Настраиваем рабочий контекст.

— Создадим контекст CTX-MAINGW.

! переходим в системные настройки
changeto system 

context CTX-MAINGW
 config-url flash:/CTX-MAINGW.CFG
 allocate-interface Port-channel1.100 WAN_ISP1_IF  
 allocate-interface Port-channel1.200 WAN_ISP2_IF  
 allocate-interface Port-channel1.300 DMZ_IF
 allocate-interface Port-channel1.400 LAN_IF

Проверяем:

ciscoasa/pri/act# sh context 
Context Name      Class      Interfaces           Mode         URL
*CTX-ADMIN        default    Port-channel1.400    Routed       disk0:/CTX-ADMIN.CFG
 CTX-MAINGW       default    Port-channel1.100,   Routed       disk0:/CTX-MAINGW.CFG
                             200,300,400         

Total active Security Contexts: 2

— Настроим интерфейсы внутри контекста CTX-MAINGW.

changeto context CTX-MAINGW

interface LAN_IF
 nameif LAN
 security-level 100
 ip address 10.18.0.1 255.255.255.0 standby 10.18.0.2

interface WAN_ISP1_IF
 nameif WAN_ISP1
 security-level 0
 ip address 1.1.1.2 255.255.255.252

interface WAN_ISP2_IF
 nameif WAN_ISP2
 security-level 0
 ip address 2.2.2.2 255.255.255.252

interface DMZ_IF
 nameif DMZ
 security-level 50
 ip address 10.200.200.1 255.255.255.0 standby 10.200.200.2

— Настраиваем маршрутизацию контекста CTX-MAINGW с провайдерами.

router ospf 1
 network 1.1.1.0 255.255.255.252 area 0
 network 2.2.2.0 255.255.255.252 area 0
 log-adj-changes

! основной провайдер
interface WAN_ISP1_IF
 ospf cost 10

! резервный провайдер
interface WAN_ISP2_IF
 ospf cost 20

Проверяем соседей:

ciscoasa/CTX-MAINGW/pri/act# sh ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/BDR        0:00:35     1.1.1.1         WAN_ISP1
2.2.2.1           1   FULL/BDR        0:00:26     2.2.2.1         WAN_ISP2

Проверяем пришел ли дефолт:

ciscoasa/CTX-MAINGW/pri/act# sh route 

Gateway of last resort is 1.1.1.1 to network 0.0.0.0

C    1.1.1.0 255.255.255.252 is directly connected, WAN_ISP1
C    2.2.2.0 255.255.255.252 is directly connected, WAN_ISP2
C    10.200.200.0 255.255.255.0 is directly connected, DMZ
C    10.18.0.0 255.255.255.0 is directly connected, LAN
O*E2 0.0.0.0 0.0.0.0 [110/1] via 1.1.1.1, 0:00:57, WAN_ISP1

— Настраиваем внутреннюю маршрутизацию.

router eigrp 1
 no auto-summary
 network 10.18.0.0 255.255.255.0
 passive-interface default
 no passive-interface LAN
 ! редистрибьюция дефолта внутрь
 redistribute ospf 1 metric 1 1 1 1 1500

Проверяем соседей:

ciscoasa/CTX-MAINGW/pri/act# sh eigrp neighbors 
EIGRP-IPv4 neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.18.0.3               LAN              9   00:03:12 82   492   0   4

Маршрутизация:

ciscoasa/CTX-MAINGW/pri/act# sh route

Gateway of last resort is 1.1.1.1 to network 0.0.0.0

C    1.1.1.0 255.255.255.252 is directly connected, WAN_ISP1
C    2.2.2.0 255.255.255.252 is directly connected, WAN_ISP2
D    10.10.10.0 255.255.255.0 [90/153600] via 10.18.0.3, 0:03:36, LAN
C    10.200.200.0 255.255.255.0 is directly connected, DMZ
C    10.18.0.0 255.255.255.0 is directly connected, LAN
O*E2 0.0.0.0 0.0.0.0 [110/1] via 1.1.1.1, 0:10:19, WAN_ISP1

Настройка оборудования лабораторного стенда.

Спойлер: Конфигурация ASAv_9.15-1
Системная конфигурация:
!
hostname ciscoasa
enable password 8Ry2YjIyt7RRXU24 encrypted
mac-address auto prefix 2
!
interface Ethernet0
channel-group 1 mode on
!
interface Ethernet1
channel-group 1 mode on
!
interface Ethernet2
shutdown
!
interface Ethernet3
shutdown
!
interface Ethernet4
shutdown
!
interface Ethernet5
shutdown
!
interface Ethernet6
channel-group 2 mode on
!
interface Ethernet7
channel-group 2 mode on
!
interface Port-channel1
description TRUNK_TO_BORDER_SW
!
interface Port-channel1.100
description WAN_ISP_1
vlan 100
!
interface Port-channel1.200
description WAN_ISP_2
vlan 200
!
interface Port-channel1.300
description DMZ
vlan 300
!
interface Port-channel1.400
description LAN
vlan 400
!
interface Port-channel2
description LAN/STATE Failover Interface
!
class default
limit-resource All 0
limit-resource Mac-addresses 65535
limit-resource ASDM 5
limit-resource SSH 5
limit-resource Telnet 5
!

ftp mode passive
pager lines 24
failover
failover lan unit primary
failover lan interface FAILOVER_IF Port-channel2
failover link FAILOVER_IF Port-channel2
failover interface ip FAILOVER_IF 192.168.0.1 255.255.255.252 standby 192.168.0.2
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
ssh stricthostkeycheck
console timeout 0

admin-context CTX-ADMIN
context CTX-ADMIN
allocate-interface Port-channel1.400 LAN_IF
config-url disk0:/CTX-ADMIN.CFG
!

context CTX-MAINGW
allocate-interface Port-channel1.100 WAN_ISP1_IF
allocate-interface Port-channel1.200 WAN_ISP2_IF
allocate-interface Port-channel1.300 DMZ_IF
allocate-interface Port-channel1.400 LAN_IF
config-url disk0:/CTX-MAINGW.CFG
!

prompt hostname context priority state
crashinfo save disable
Cryptochecksum:e8d53c1dff945fb96d9e3582c17fc6c4
: end

Конфигурация административного контекста:
!
hostname CTX-ADMIN
domain-name HQ.CORP
enable password 8Ry2YjIyt7RRXU24 encrypted
names
!
interface LAN_IF
nameif LAN
security-level 100
ip address 10.18.0.11 255.255.255.0 standby 10.18.0.12
!
dns server-group DefaultDNS
domain-name HQ.CORP
pager lines 24
mtu LAN 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
!
router eigrp 1
no auto-summary
network 10.18.0.0 255.255.255.0
passive-interface default
no passive-interface LAN
!
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec security-association pmtu-aging infinite
telnet timeout 5
ssh stricthostkeycheck
ssh 10.0.0.0 255.0.0.0 LAN
ssh timeout 5
ssh version 2
ssh key-exchange group dh-group1-sha1
no threat-detection statistics tcp-intercept
username cisco password 3USUcOPFUiMCO4Jk encrypted privilege 15
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect ip-options
inspect netbios
inspect rsh
inspect rtsp
inspect skinny
inspect esmtp
inspect sqlnet
inspect sunrpc
inspect tftp
inspect sip
inspect xdmcp
!
service-policy global_policy global
Cryptochecksum:818ba71743939c2a50871181cc06d680
: end

Конфигурация рабочего контекста:
!
hostname CTX-MAINGW
enable password 8Ry2YjIyt7RRXU24 encrypted
names
!
interface WAN_ISP2_IF
nameif WAN_ISP2
security-level 0
ip address 2.2.2.2 255.255.255.252
ospf cost 20
!
interface DMZ_IF
nameif DMZ
security-level 50
ip address 10.200.200.1 255.255.255.0 standby 10.200.200.2
!
interface LAN_IF
nameif LAN
security-level 100
ip address 10.18.0.1 255.255.255.0 standby 10.18.0.2
!
interface WAN_ISP1_IF
nameif WAN_ISP1
security-level 0
ip address 1.1.1.2 255.255.255.252
ospf cost 10
!
pager lines 24
mtu LAN 1500
mtu WAN_ISP1 1500
mtu WAN_ISP2 1500
mtu DMZ 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
!
router eigrp 1
no auto-summary
network 10.18.0.0 255.255.255.0
passive-interface default
no passive-interface LAN
redistribute ospf 1 metric 1 1 1 1 1500
!
router ospf 1
network 1.1.1.0 255.255.255.252 area 0
network 2.2.2.0 255.255.255.252 area 0
log-adj-changes
!
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
user-identity default-domain LOCAL
no snmp-server location
no snmp-server contact
crypto ipsec security-association pmtu-aging infinite
telnet timeout 5
ssh stricthostkeycheck
ssh timeout 5
ssh key-exchange group dh-group1-sha1
no threat-detection statistics tcp-intercept
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect ip-options
inspect netbios
inspect rsh
inspect rtsp
inspect skinny
inspect esmtp
inspect sqlnet
inspect sunrpc
inspect tftp
inspect sip
inspect xdmcp
inspect icmp
!
service-policy global_policy global
Cryptochecksum:eaab9c558787467114256ed6917884a0
: end

Спойлер: Конфигурация ASAv_9.15-2
Системная конфигурация:
!
hostname ciscoasa
enable password 8Ry2YjIyt7RRXU24 encrypted
mac-address auto prefix 2
!
interface Ethernet0
channel-group 1 mode on
!
interface Ethernet1
channel-group 1 mode on
!
interface Ethernet2
shutdown
!
interface Ethernet3
shutdown
!
interface Ethernet4
shutdown
!
interface Ethernet5
shutdown
!
interface Ethernet6
channel-group 2 mode on
!
interface Ethernet7
channel-group 2 mode on
!
interface Port-channel1
description TRUNK_TO_BORDER_SW
!
interface Port-channel1.100
description WAN_ISP_1
vlan 100
!
interface Port-channel1.200
description WAN_ISP_2
vlan 200
!
interface Port-channel1.300
description DMZ
vlan 300
!
interface Port-channel1.400
description LAN
vlan 400
!
interface Port-channel2
description LAN/STATE Failover Interface
!
class default
limit-resource All 0
limit-resource Mac-addresses 65535
limit-resource ASDM 5
limit-resource SSH 5
limit-resource Telnet 5
!
ftp mode passive
pager lines 24
failover
failover lan unit secondary
failover lan interface FAILOVER_IF Port-channel2
failover link FAILOVER_IF Port-channel2
failover interface ip FAILOVER_IF 192.168.0.1 255.255.255.252 standby 192.168.0.2
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
ssh stricthostkeycheck
console timeout 0

admin-context CTX-ADMIN
context CTX-ADMIN
allocate-interface Port-channel1.400 LAN_IF
config-url disk0:/CTX-ADMIN.CFG
!

context CTX-MAINGW
allocate-interface Port-channel1.100 WAN_ISP1_IF
allocate-interface Port-channel1.200 WAN_ISP2_IF
allocate-interface Port-channel1.300 DMZ_IF
allocate-interface Port-channel1.400 LAN_IF
config-url disk0:/CTX-MAINGW.CFG
!
prompt hostname context priority state
crashinfo save disable
Cryptochecksum:9ce38632e8c1f1b73f01d7ae6a02465f
: end

Конфигурация контекстов идентичны ASAv_9.15-1

Спойлер: Конфигурация vIOS-L2-1
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
vtp mode off
!
shutdown vlan 666
!
ip cef
no ipv6 cef
!
spanning-tree mode pvst
spanning-tree extend system-id
no spanning-tree vlan 1-4094
!
vlan internal allocation policy ascending
!
vlan 100,200,300,400
!
vlan 666
shutdown
!
!
interface Port-channel1
switchport trunk allowed vlan 100,200,300,400
switchport trunk encapsulation dot1q
switchport trunk native vlan 666
switchport mode trunk
!
interface Port-channel2
switchport trunk allowed vlan 100,200,300,400
switchport trunk encapsulation dot1q
switchport trunk native vlan 666
switchport mode trunk
!
interface GigabitEthernet0/0
switchport trunk allowed vlan 100,200,300,400
switchport trunk encapsulation dot1q
switchport trunk native vlan 666
switchport mode trunk
media-type rj45
negotiation auto
channel-group 1 mode on
!
interface GigabitEthernet0/1
switchport trunk allowed vlan 100,200,300,400
switchport trunk encapsulation dot1q
switchport trunk native vlan 666
switchport mode trunk
media-type rj45
negotiation auto
channel-group 1 mode on
!
interface GigabitEthernet0/2
switchport trunk allowed vlan 100,200,300,400
switchport trunk encapsulation dot1q
switchport trunk native vlan 666
switchport mode trunk
media-type rj45
negotiation auto
channel-group 2 mode on
!
interface GigabitEthernet0/3
switchport trunk allowed vlan 100,200,300,400
switchport trunk encapsulation dot1q
switchport trunk native vlan 666
switchport mode trunk
media-type rj45
negotiation auto
channel-group 2 mode on
!
interface GigabitEthernet1/0
switchport access vlan 100
switchport mode access
media-type rj45
negotiation auto
!
interface GigabitEthernet1/1
switchport access vlan 200
switchport mode access
media-type rj45
negotiation auto
!
interface GigabitEthernet1/2
switchport access vlan 300
switchport mode access
media-type rj45
negotiation auto
!
interface GigabitEthernet1/3
switchport access vlan 400
switchport mode access
media-type rj45
negotiation auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
control-plane
!
line con 0
line aux 0
line vty 0 4
login
!
end

Спойлер: Конфигурация GW_ISP_1
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname GW_ISP_1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
no ip domain lookup
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
ip address 1.1.1.1 255.255.255.252
speed auto
duplex auto
!
interface FastEthernet0/1
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/1
no ip address
shutdown
speed auto
duplex auto
!
router ospf 1
network 1.1.1.0 0.0.0.3 area 0
default-information originate always
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
end
Спойлер: Конфигурация GW_ISP_2
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname GW_ISP_2
!
boot-start-marker
boot-end-marker
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
ip address 2.2.2.1 255.255.255.252
speed auto
duplex auto
!
interface FastEthernet0/1
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/1
no ip address
shutdown
speed auto
duplex auto
!
router ospf 1
network 2.2.2.0 0.0.0.3 area 0
default-information originate always
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end
Спойлер: Конфигурация LAN_CORE_GW
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname LAN_CORE_GW
!
boot-start-marker
boot-end-marker
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
ip tcp synwait-time 5
!
!
interface Loopback10
ip address 10.10.10.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.18.0.3 255.255.255.0
speed auto
duplex auto
!
interface FastEthernet0/1
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/1
no ip address
shutdown
speed auto
duplex auto
!
!
router eigrp 1
network 10.0.0.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *