iRWX.RU

Personal IT notes.

Cisco: EtherChannel на маршрутизаторах ISR.

Небольшая заметка на тему EtherChannel (PortChannel) на маршрутизаторах Cisco ISR.

Настроим на следующем примере:

Схема физическая:

Схема логическая:

Требуется настроить доступ с PC_vlan10 к PC_vlan20 и наоборот, а также доступ в сеть Internet.

EtherChannel на Cisco ISR весьма урезанный в возможностях:
— только 4 интерфейса на 1 агрегированный канал;
— только статический агрегированный канал (mode ON);
— нет настройки метода балансировки, только src-dst-IP.

Настройка

— Сначала на маршрутизаторе создается сам интерфейс:

interface Port-channel1
no sh

— Потом интерфейсы добавляются в агрегированный канал:

interface FastEthernet0/0
 channel-group 1
 no sh

interface FastEthernet0/1
 channel-group 1
 no sh

Все дальнейшие действия с интерфейсом Port-channel1 производим как с обычным L3 интерфейсом маршрутизатора.

— Разбираем теги VLAN на субинтерфейсы, назначаем IP адреса и сразу указываем принадлежность NAT:

interface Port-channel1.5
 encapsulation dot1Q 5
 ip address 1.1.1.2 255.255.255.252
 ip nat outside

interface Port-channel1.10
 encapsulation dot1Q 10
 ip address 10.10.10.1 255.255.255.0
 ip nat inside

interface Port-channel1.20
 encapsulation dot1Q 20
 ip address 10.10.20.1 255.255.255.0
 ip nat inside

— Настройка NAT и указание дефолта на провайдера:

ip access-list extended ACL_NAT
 permit ip 10.10.0.0 0.0.255.255 any

ip nat inside source list ACL_NAT interface Port-channel1.5 overload

ip route 0.0.0.0 0.0.0.0 1.1.1.1

Конфигурации оборудования:

RTR
!
version 15.2
!
hostname RTR
!
!
interface Port-channel1
no ip address
!
interface Port-channel1.5
encapsulation dot1Q 5
ip address 1.1.1.2 255.255.255.252
ip nat outside
!
interface Port-channel1.10
encapsulation dot1Q 10
ip address 10.10.10.1 255.255.255.0
ip nat inside
!
interface Port-channel1.20
encapsulation dot1Q 20
ip address 10.10.20.1 255.255.255.0
ip nat inside
!
interface FastEthernet0/0
no ip address
channel-group 1
!
interface FastEthernet0/1
no ip address
channel-group 1
!
ip nat inside source list ACL_NAT interface Port-channel1.5 overload
!
ip route 0.0.0.0 0.0.0.0 1.1.1.1
!
ip access-list extended ACL_NAT
permit ip 10.10.0.0 0.0.255.255 any
!
SW
!
version 15.2
!
hostname Switch
!
vtp mode off
vlan 5,10,20
!
!
interface Port-channel1
switchport trunk allowed vlan 5,10,20
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/0
switchport trunk allowed vlan 5,10,20
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode on
!
interface GigabitEthernet0/1
switchport trunk allowed vlan 5,10,20
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode on
!
interface GigabitEthernet1/0
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/1
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet1/2
switchport access vlan 5
switchport mode access
!
Internet
!
version 15.2
!
hostname Internet
!
interface Loopback10
ip address 8.8.8.8 255.255.255.255
!
interface FastEthernet0/0
ip address 1.1.1.1 255.255.255.252
!

PS
После написания данной заметки нашел статью с похожим на мой примером. В статье указано ограничение в настройки только 2 агрегированных интерфейсов. На моем стенде это не подтвердилось, хотя это возможно из-за виртуализации моего стенда.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *